#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:dossier|facture|visite)\s*n\xB0\s*(?:INC|MAINT)[0-9]+"
Local $sString = " " & @CRLF & _
" CALNET à l'équipe COFELY RAA " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Vous venez de signaler la réalisation de la visite de maintenance pour la visite n° MAINT0218037 faite le 21/05/2019 14:22:30 sur le site RRAA BRIOUDE (00223200). Il vous reste maintenant à publier le rapport de maintenance dans CALNET. " & @CRLF & _
" " & @CRLF & _
" Pour ce faire, vous pouvez accéder au dossier en cliquant sur ce lien : ici . " & @CRLF & _
" Cordialement " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")