using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:dossier|facture|visite)\s*n\xB0\s*(?:INC|MAINT)[0-9]+";
string input = @"
CALNET à l'équipe COFELY RAA
Vous venez de signaler la réalisation de la visite de maintenance pour la visite n° MAINT0218037 faite le 21/05/2019 14:22:30 sur le site RRAA BRIOUDE (00223200). Il vous reste maintenant à publier le rapport de maintenance dans CALNET.
Pour ce faire, vous pouvez accéder au dossier en cliquant sur ce lien : ici .
Cordialement
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}