$re = '/(?:dossier|facture|visite)\s*n\xB0\s*(?:INC|MAINT)[0-9]+/m';
$str = '
CALNET à l\'équipe COFELY RAA
Vous venez de signaler la réalisation de la visite de maintenance pour la visite n° MAINT0218037 faite le 21/05/2019 14:22:30 sur le site RRAA BRIOUDE (00223200). Il vous reste maintenant à publier le rapport de maintenance dans CALNET.
Pour ce faire, vous pouvez accéder au dossier en cliquant sur ce lien : ici .
Cordialement
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);