import re
regex = re.compile(r"(?:dossier|facture|visite)\s*n\xB0\s*(?:INC|MAINT)[0-9]+", flags=re.MULTILINE)
test_str = (" \n"
" CALNET à l'équipe COFELY RAA \n"
" \n"
" \n"
" \n"
" Vous venez de signaler la réalisation de la visite de maintenance pour la visite n° MAINT0218037 faite le 21/05/2019 14:22:30 sur le site RRAA BRIOUDE (00223200). Il vous reste maintenant à publier le rapport de maintenance dans CALNET. \n"
" \n"
" Pour ce faire, vous pouvez accéder au dossier en cliquant sur ce lien : ici . \n"
" Cordialement \n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")