import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:dossier|facture|visite)\\s*n\\xB0\\s*(?:INC|MAINT)[0-9]+";
final String string = " \n"
+ " CALNET à l'équipe COFELY RAA \n"
+ " \n"
+ " \n"
+ " \n"
+ " Vous venez de signaler la réalisation de la visite de maintenance pour la visite n° MAINT0218037 faite le 21/05/2019 14:22:30 sur le site RRAA BRIOUDE (00223200). Il vous reste maintenant à publier le rapport de maintenance dans CALNET. \n"
+ " \n"
+ " Pour ce faire, vous pouvez accéder au dossier en cliquant sur ce lien : ici . \n"
+ " Cordialement \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}