#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[0-9]+( ?)(yo|years old|years o|yearso|yold)"
Local $sString = "i'm 19yo okyo " & @CRLF & _
"yo" & @CRLF & _
"mehyo" & @CRLF & _
"154165165165yo" & @CRLF & _
"ok years old" & @CRLF & _
"19 years old" & @CRLF & _
"19y old" & @CRLF & _
"19yold" & @CRLF & _
"19 yold" & @CRLF & _
"yo what's up" & @CRLF & _
"4564564years old" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")