re = /[0-9]+( ?)(yo|years old|years o|yearso|yold)/mi
str = 'i\'m 19yo okyo
yo
mehyo
154165165165yo
ok years old
19 years old
19y old
19yold
19 yold
yo what\'s up
4564564years old
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end