import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+( ?)(yo|years old|years o|yearso|yold)";
final String string = "i'm 19yo okyo \n"
+ "yo\n"
+ "mehyo\n"
+ "154165165165yo\n"
+ "ok years old\n"
+ "19 years old\n"
+ "19y old\n"
+ "19yold\n"
+ "19 yold\n"
+ "yo what's up\n"
+ "4564564years old\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}