package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[0-9]+( ?)(yo|years old|years o|yearso|yold)`)
var str = `i'm 19yo okyo
yo
mehyo
154165165165yo
ok years old
19 years old
19y old
19yold
19 yold
yo what's up
4564564years old
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}