// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[0-9]+( ?)(yo|years old|years o|yearso|yold)").unwrap();
let string = "i'm 19yo okyo
yo
mehyo
154165165165yo
ok years old
19 years old
19y old
19yold
19 yold
yo what's up
4564564years old
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}