use strict;
my $str = 'i\'m 19yo okyo
yo
mehyo
154165165165yo
ok years old
19 years old
19y old
19yold
19 yold
yo what\'s up
4564564years old
';
my $regex = qr/[0-9]+( ?)(yo|years old|years o|yearso|yold)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}