const regex = /[0-9]+( ?)(yo|years old|years o|yearso|yold)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+( ?)(yo|years old|years o|yearso|yold)', 'gmi')
const str = `i'm 19yo okyo
yo
mehyo
154165165165yo
ok years old
19 years old
19y old
19yold
19 yold
yo what's up
4564564years old
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}