# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\/(abc\d{2})(?:\/.*)?$/\1/gm;t' <<< "/path/path/path/abc22/path/path
/apath/apath/paath/abc11/something/path"