#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*/(abc\d{2})(?:/.*)?$"
Local $sString = "/path/path/path/abc22/path/path" & @CRLF & _
"/apath/apath/paath/abc11/something/path"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)