const regex = new RegExp('^.*/(abc\\d{2})(?:/.*)?$', 'gm')
const str = `/path/path/path/abc22/path/path
/apath/apath/paath/abc11/something/path`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);