import re
regex = re.compile(r"^.*/(abc\d{2})(?:/.*)?$", flags=re.MULTILINE)
test_str = ("/path/path/path/abc22/path/path\n"
"/apath/apath/paath/abc11/something/path")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)