$re = '@^.*/(abc\d{2})(?:/.*)?$@m';
$str = '/path/path/path/abc22/path/path
/apath/apath/paath/abc11/something/path';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;