package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*/(abc\d{2})(?:/.*)?$`)
var str = `/path/path/path/abc22/path/path
/apath/apath/paath/abc11/something/path`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}