# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=_).+//gm;t' <<< "John Smith_12345678_
Mary Scott_87945687_
William Tell_9875348_
Jane Doe_57982388_"