use strict;
my $str = 'John Smith_12345678_
Mary Scott_87945687_
William Tell_9875348_
Jane Doe_57982388_';
my $regex = qr/(?<=_).+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";