re = /(?<=_).+/m
str = 'John Smith_12345678_
Mary Scott_87945687_
William Tell_9875348_
Jane Doe_57982388_'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result