const regex = new RegExp('(?<=_).+', 'gm')
const str = `John Smith_12345678_
Mary Scott_87945687_
William Tell_9875348_
Jane Doe_57982388_`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);