$re = '/(?<=_).+/m';
$str = 'John Smith_12345678_
Mary Scott_87945687_
William Tell_9875348_
Jane Doe_57982388_';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;