#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=_).+"
Local $sString = "John Smith_12345678_" & @CRLF & _
"Mary Scott_87945687_" & @CRLF & _
"William Tell_9875348_" & @CRLF & _
"Jane Doe_57982388_"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)