# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^.*\\/)([^\d]*\d)(?:\\/?$)/\1/gm;t' <<< "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/sno3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_33/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/33/"