// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^.*\/)([^\d]*\d)(?:\/?$)").unwrap();
let string = "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/sno3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_33/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/33/";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}