use strict;
my $str = 'https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/sno3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_33/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/33/';
my $regex = qr/(?:^.*\/)([^\d]*\d)(?:\/?$)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";