re = /(?:^.*\/)([^\d]*\d)(?:\/?$)/m
str = 'https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/sno3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_33/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/33/'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result