const regex = new RegExp('(?:^.*\\/)([^\\d]*\\d)(?:\\/?$)', 'gm')
const str = `https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/sno3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/3/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_33/
https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/33/`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);