#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^.*\/)([^\d]*\d)(?:\/?$)"
Local $sString = "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_3/" & @CRLF & _
"https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/sno3/" & @CRLF & _
"https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/3/" & @CRLF & _
"https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide/" & @CRLF & _
"https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_33/" & @CRLF & _
"https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/33/"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)