import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^.*\\/)([^\\d]*\\d)(?:\\/?$)";
final String string = "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_3/\n"
+ "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/sno3/\n"
+ "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/3/\n"
+ "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide/\n"
+ "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/slide_33/\n"
+ "https://facty.com/ailments/body/10-home-remedies-for-styes/pageid=2/33/";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}