import re
regex = re.compile(r"\s*([*/+-]?=)\s*", flags=re.MULTILINE)
test_str = ("a=\"a\"\n"
"b= \"b\"\n"
"b +=\"b\"\n"
"c = \"c\"")
subst = " \\1 "
result = regex.sub(subst, test_str)
if result:
print(result)