re = /\s*([*\/+-]?=)\s*/m
str = 'a="a"
b= "b"
b +="b"
c = "c"'
subst = ' \\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result