#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<span class="pv-entity__secondary-title">(.*?)<\/span>"
Local $sString = "<h4 class="t-16 t-black t-normal">" & @CRLF & _
" <span class="visually-hidden">Company Name</span>" & @CRLF & _
" <span class="pv-entity__secondary-title">Taldor</span>" & @CRLF & _
" </h4>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")