re = /<span class="pv-entity__secondary-title">(.*?)<\/span>/m
str = '<h4 class="t-16 t-black t-normal">
<span class="visually-hidden">Company Name</span>
<span class="pv-entity__secondary-title">Taldor</span>
</h4>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end