import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\"pv-entity__secondary-title\">(.*?)<\\/span>";
final String string = "<h4 class=\"t-16 t-black t-normal\">\n"
+ " <span class=\"visually-hidden\">Company Name</span>\n"
+ " <span class=\"pv-entity__secondary-title\">Taldor</span>\n"
+ " </h4>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}