package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span class="pv-entity__secondary-title">(.*?)<\/span>`)
var str = `<h4 class="t-16 t-black t-normal">
<span class="visually-hidden">Company Name</span>
<span class="pv-entity__secondary-title">Taldor</span>
</h4>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}