// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span class="pv-entity__secondary-title">(.*?)<\/span>"#).unwrap();
let string = "<h4 class=\"t-16 t-black t-normal\">
<span class=\"visually-hidden\">Company Name</span>
<span class=\"pv-entity__secondary-title\">Taldor</span>
</h4>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}