import re
regex = re.compile(r"<span class=\"pv-entity__secondary-title\">(.*?)<\/span>", flags=re.MULTILINE)
test_str = ("<h4 class=\"t-16 t-black t-normal\">\n"
" <span class=\"visually-hidden\">Company Name</span>\n"
" <span class=\"pv-entity__secondary-title\">Taldor</span>\n"
" </h4>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")