#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\.{1,2}(?:\/[[:alnum:]]*)*)"
Local $sString = "The first relative path . or ./some/file/path" & @CRLF & _
"" & @CRLF & _
"The second relative path is .. or ../some/file/path" & @CRLF & _
"" & @CRLF & _
"Where the length of "/some/file/path" is arbitrary"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")