package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\.{1,2}(?:\/[[:alnum:]]*)*)`)
var str = `The first relative path . or ./some/file/path
The second relative path is .. or ../some/file/path
Where the length of "/some/file/path" is arbitrary`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}