import re
regex = re.compile(r"(\.{1,2}(?:\/[[:alnum:]]*)*)")
test_str = ("The first relative path . or ./some/file/path\n\n"
"The second relative path is .. or ../some/file/path\n\n"
"Where the length of \"/some/file/path\" is arbitrary")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")