$re = '/(\.{1,2}(?:\/[[:alnum:]]*)*)/';
$str = 'The first relative path . or ./some/file/path
The second relative path is .. or ../some/file/path
Where the length of "/some/file/path" is arbitrary';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);