re = /(\.{1,2}(?:\/[[:alnum:]]*)*)/
str = 'The first relative path . or ./some/file/path
The second relative path is .. or ../some/file/path
Where the length of "/some/file/path" is arbitrary'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end