import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.{1,2}(?:\\/[[:alnum:]]*)*)";
final String string = "The first relative path . or ./some/file/path\n\n"
+ "The second relative path is .. or ../some/file/path\n\n"
+ "Where the length of \"/some/file/path\" is arbitrary";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}