# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|[^"])(Level\s+\d+)(?!["\d])/$1"$2"/g;t' <<< "\"Level 3 protected\": Level 4 here and \"another Level 5\""