use strict;
my $str = '"Level 3 protected": Level 4 here and "another Level 5"';
my $regex = qr/(^|[^"])(Level\s+\d+)(?!["\d])/p;
my $subst = '$1"$2"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";