const regex = /(^|[^"])(Level\s+\d+)(?!["\d])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^"])(Level\\s+\\d+)(?!["\\d])', 'g')
const str = `"Level 3 protected": Level 4 here and "another Level 5"`;
const subst = `$1"$2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);