import re
regex = re.compile(r"(^|[^\"])(Level\s+\d+)(?![\"\d])")
test_str = "\"Level 3 protected\": Level 4 here and \"another Level 5\""
subst = "$1\"$2\""
result = regex.sub(subst, test_str)
if result:
print(result)