#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-zA-Z][a-zA-Z0-9_]*)\s*=\s*(|['"])(.+)\2"
Local $sString = "#!/bin/bash" & @CRLF & _
"foo = "Hello world!"" & @CRLF & _
"bar="123"" & @CRLF & _
"x=1" & @CRLF & _
"z='test'" & @CRLF & _
"echo -e "The value of foo is $foo\n"" & @CRLF & _
"echo -e "The value of bar is $bar"" & @CRLF & _
"';"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")